Partial service disruption on multiple sites.
Incident Report for Faithlife
Resolved
This incident has been resolved.
Posted Nov 02, 2022 - 21:52 PDT
Update
We are continuing to monitor for any further issues.
Posted Nov 02, 2022 - 21:45 PDT
Monitoring
One of our cloud service providers is experiencing a networking issue which is preventing our apps from functioning normally.
Posted Nov 02, 2022 - 20:28 PDT
This incident affected: Logos Bible Software/Verbum (App.logos.com) and Amber.Faithlife.com, Faithlife Giving, Faithlife Sermons, Faithlife TV.