ChMS is in read-only mode
Incident Report for Faithlife
Resolved
This incident has been resolved.
Posted Mar 17, 2021 - 18:05 PDT
Investigating
We're experiencing an outage affecting all edit/create operations for ChMS People records, and are actively working on a resolution. Attempts to edit or create records are currently failing.
Posted Mar 17, 2021 - 17:36 PDT
This incident affected: Faithlife.com (Faithlife.com).