Logos.com is down due to database server maintenance
Incident Report for Faithlife
Resolved
This incident has been resolved.
Posted Mar 19, 2024 - 22:24 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 19, 2024 - 22:05 PDT
Investigating
We are currently investigating an issue with our services going down due to database maintenance. We will keep this page updated as we continue to learn more and work to resolve the issue.
Posted Mar 19, 2024 - 21:35 PDT
This incident affected: Core Services (Accounts API), Faithlife.com (Faithlife.com, Community API), Logos Bible Software/Verbum (Logos.com, Verbum.com, Sign In), and Faithlife Ebooks.