Inclement Pacific Northwest weather
Incident Report for Faithlife
Resolved
The storm was much less intense than originally forecast, and had no adverse effects on Faithlife operations.
Posted 9 months ago. Oct 16, 2016 - 08:22 PDT
Monitoring
Northwest Washington has a heavy storm incoming. Both our datacenters in Washington have adequate redundancy for an extended power outage. Our Sales, Accounting, and Customer Support departments may be unavailable during the storm. We'll be monitoring the situation and keeping services online as best we can.
Posted 9 months ago. Oct 12, 2016 - 15:23 PDT