Proclaim Sync
Incident Report for Faithlife
Resolved
This incident has been resolved.
Posted 9 months ago. Jan 09, 2018 - 13:05 PST
Investigating
We are investigating an issue with syncing presentations in Proclaim.
Posted 9 months ago. Jan 09, 2018 - 09:25 PST