Network outage
Incident Report for Faithlife
Resolved
This incident has been resolved.
Posted about 1 year ago. Oct 05, 2016 - 09:40 PDT
Monitoring
The issue has been resolved, but we'll continue to monitor the situation.
Posted about 1 year ago. Oct 04, 2016 - 21:49 PDT
Investigating
All Faithlife sites and services are experiencing issues, we are actively investigating.
Posted about 1 year ago. Oct 04, 2016 - 21:43 PDT