Faithlife TV partial outage, some video unavailable
Incident Report for Faithlife
Resolved
This incident has been resolved.
Posted 20 days ago. Oct 02, 2017 - 10:33 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted 20 days ago. Oct 02, 2017 - 10:00 PDT