sermons.faithlife.com outage
Incident Report for Faithlife
Resolved
This incident has been resolved.
Posted 23 days ago. Sep 25, 2018 - 13:42 PDT
Investigating
sermons.faithlife.com is currently experiencing an outage. We are actively investigating the situation.

The following are affected:
* Proclaim sermon audio publishing
* Faithlife Sites sermons
Posted 23 days ago. Sep 25, 2018 - 10:26 PDT