Proclaim Sync Outage
Incident Report for Faithlife
Resolved
The issue has been resolved.
Posted 3 months ago. Jan 24, 2018 - 23:55 PST
Identified
We're experiencing an issue with the Proclaim Sync database and are currently looking into the issue.
Posted 3 months ago. Jan 24, 2018 - 23:06 PST