Network outage
Incident Report for Faithlife
Resolved
This incident has been resolved.
Posted 7 months ago. May 17, 2017 - 00:12 PDT
Investigating
We are currently experiencing a network outage in our data center. All Faithlife sites and services are currently down or degraded. We will keep you updated.
Posted 7 months ago. May 16, 2017 - 22:50 PDT