Network outage
Incident Report for Faithlife
Resolved
Faithlife sites and services are fully functioning again.
Posted about 1 year ago. Oct 19, 2016 - 00:52 PDT
Investigating
We are currently experiencing network issues in our main data center. Most Faithlife sites and services are currently degraded. We'll keep you updated.
Posted about 1 year ago. Oct 19, 2016 - 00:10 PDT