Logos Web App degraded performance
Incident Report for Faithlife
Resolved
This incident has been resolved.
Posted 19 days ago. Oct 29, 2018 - 20:34 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 20 days ago. Oct 29, 2018 - 16:08 PDT
Investigating
We are currently investigating issues accessing app.logos.com.
Posted 20 days ago. Oct 29, 2018 - 12:26 PDT