Intermittent errors on Faithlife.com posts and messages
Incident Report for Faithlife
Resolved
This incident has been resolved.
Posted 2 months ago. May 31, 2018 - 16:38 PDT
Investigating
We are currently investigating problems creating new posts and messages on Faithlife.com.
Posted 2 months ago. May 31, 2018 - 13:44 PDT
This incident affected: Faithlife.com (Community API, Faithlife.com).